[JOKER POKER] Plus d'affichage en cours de partie

Aide, Dépannage, pour les flippers numérique ou alpha-numérique (lettre + chiffre)

Flipper concerné :

Si necessaire, merci de proposer un flipper en relation avec ce sujet.
Répondre
NikosDeMikonos
Dept: 78
Rech/Achete: 0 flip
Messages : 15
Enregistré le : mar. 03 10, 2017 12:34
Niveau : Débutant
Pro / revendeur : non

[JOKER POKER] Plus d'affichage en cours de partie

Message par NikosDeMikonos » dim. 10 11, 2019 18:33

Bonjour à tous !

J'avais enfin fini ma restauration d'un "Joker Poker" et m'apprêtait à restituer mon expérience sur le forum, mais voila, après 3 semaines de partie acharnées les afficheurs ont lachés d'un coup ! Juste pour le contexte, mon petit appuyait de manière "inapropriée" sur le bouton "credit" en pleine partie, ce qui n'est pas je pense vraiment prévu par Pascal Janin ...

Il s'agit donc d'un Gottlieb System 1 , équipé d'une carte Janin PX4 (l'originale étant en très sale état).

Ayant regardé la doc, j'ai compris que le micro-fusible de la carte Janin avait laché. J'ai essayé de remettre le spare fourni avec , relachage immédiat ...

Je me suis donc lancé dans le debut des cartes afficheurs, en suivant une methodo avec un multimètre sur les UDN6118A (mesure en mode "diode" entre la pin GND et chacune des entrées sorties).
Image

Le résultat aurait pu être concluant : l'afficheur 3 présente une valeur en mesure de diode sur une des sorties ce qui est anormal.

MAIS ! N'étant plus sur s'il fallait retirer les connecteurs avant de faire cette mesure, je les ai retiré et la , très bizarre résultats :
Afficheur 1 : UDN Ko (les 2), aucune valeur sur aucune des PIN
Afficheur 2 : UDN Ko (les 2), aucune valeur sur aucune des PIN
Afficheur 3 : Tout bon, sauf une sortie qui semble être en court circuit , et surement à l'origine de la panne ...
Afficheur 4 : Tout bon
Afficheur Compteur : Tout bon

Si je remet le connecteur, je retrouve des valeurs sur les UDN des afficheurs 1 et 2. Incompréhensible.

Voila, je ne comprends pas comment autant de dégats auraient pu apparaitre en même temps. je n'ai pas de fusible sous la main de 100ma pour refaire des tests hélas, je vais m'en procurer un stock !

Avez vous déjà rencontré une pareille situation ? Merci d'avance de vos éclaircissements si vous voyez ou je me plante :?
Modifié en dernier par NikosDeMikonos le ven. 15 11, 2019 19:08, modifié 1 fois.

Avatar du membre
DropTarget
Dept: 59
Collec Perso: 9 flips
Rech/Achete: 1 flip
Messages : 401
Enregistré le : lun. 25 05, 2015 13:47
Niveau : Confirmé
Pro / revendeur : non
Localisation : Lille

Re: [JOKER POKER] Plus d'affichage en cours de partie

Message par DropTarget » dim. 10 11, 2019 21:06

Salut,

J'ai rencontré un problème similaire sur un Gottlieb Totem avec une carte PI-1/X4 (P.Janin).
J'avais découvert qu'il y avait, en effet, un mini fusible sur la carte.
Ce dernier sautait à cause d'un des afficheurs, que j'ai identifié rapidement et installé sur un de mes autres flippers.
En examinant l'afficheur en question, je n'avais rien constaté d'anormal.
C'est curieux, l'afficheur en question est installé sur un Gottlieb Genie, équipé quant à lui, d'une carte PI-1 (P.Janin).
Et là, il n'y a jamais eu aucun problème...
Les courants de consommation des afficheurs peuvent varier d'un à l'autre, il est possible que la protection (fusible de 300mA si ma mémoire est bonne), est peut-être un peu trop sensible...

NikosDeMikonos
Dept: 78
Rech/Achete: 0 flip
Messages : 15
Enregistré le : mar. 03 10, 2017 12:34
Niveau : Débutant
Pro / revendeur : non

Re: [JOKER POKER] Plus d'affichage en cours de partie

Message par NikosDeMikonos » lun. 11 11, 2019 14:06

Merci pour ta reponse,

Effectivement le fusible (100mA) est sensible mais c’est pour le bien de l’electronique.

En revanche mon probleme c’est vraiment l’absence de mesure sur les 4 UDB des afficheurs 1&2 suite a cette panne.

Tous les afficheurs marchaient bien avant la panne j’ai du mal a croire que j’ai pu tuer 2 afficheurs d’un coup...

Merci au specialistes du forum si vous avez des pistes !

NikosDeMikonos
Dept: 78
Rech/Achete: 0 flip
Messages : 15
Enregistré le : mar. 03 10, 2017 12:34
Niveau : Débutant
Pro / revendeur : non

Re: [JOKER POKER] Plus d'affichage en cours de partie

Message par NikosDeMikonos » lun. 11 11, 2019 21:24

Suite de l'aventure ...

J'ai pu remettre un fusible temporaire sur la carte PX4.

J'ai rebranché un à un les afficheurs, sauf le 3 qui montrait au multimètre un "short" au niveau d'un UDN6118. Tout marche parfaitement bien à nouveau.

J'avoue ne pas comprendre, les afficheurs 1 & 2 ne montrent toujours pas les bonnes valeurs sur leurs composants internes si on en croit la procédure de test, pour autant ils marchent tout a fait correctement.

J'ai dessoudé l'UDN en faute et remplacé par un support à souder en attendant d'avoir le composant de rechange, la mise en oeuvre sera rapide.

Bref toujours pas compris, mais c'est "jouable" :roll:

NikosDeMikonos
Dept: 78
Rech/Achete: 0 flip
Messages : 15
Enregistré le : mar. 03 10, 2017 12:34
Niveau : Débutant
Pro / revendeur : non

Re: [JOKER POKER] Plus d'affichage en cours de partie

Message par NikosDeMikonos » ven. 15 11, 2019 18:45

Et je clos le sujet puisque j'ai complètement résolu mon problème :-)

Donc après réception d'une paire de 6118 , réinstallation sur mon support déjà soudé sur l'afficheur, ça remarche parfaitement. Cet afficheur d'ailleurs était plus faiblard depuis le début de la remise en route, je n'ai plus le problème ce qui prouve sans doute que la panne se préparait.

Je précise qu'en ayant dessoudé le composant, je l'ai re-testé au multimètre en mode "diode" et que j'ai bien retrouvé une des pins de sortie qui affichait une valeur en mV montrant une continuité.

Cela dit : clairement le test chopé sur Pinside (voir dans le post initial) n'est en aucun cas une vérité sur ce composant !
1/ sur 2 de mes afficheurs les pins inputs sortent en circuit ouvert avec le test pinside. Ils marchent parfaitement bien pourtant
2/ La valeur que je trouve quand j'en trouve une sur GND/Pin d'entrée c'est plutôt 1,4v et non pas 0,7 soit 2 jonctions PN. J'ai pu le vérifier sur le composant neuf que je viens de réceptionner
3/ quand on regarde de quoi est fait ce composant, on comprends qu'on ne peut en aucun cas tester sérieusement sans passer par un test de mesure en sortie avec un Oscillo et du régime transitoire en entrée. Donc a part trouver une différence entre les afficheurs et isoler celui qui ne fonctionne pas (ce qui a marché pour moi) , il n'y rien de réellement certain dans tout ça.

Au passage, un grand merci à Pascal Janin qui m'a fait le plaisir d'échanger sur ce sujet, non seulement sa carte est magique mais il est bien sympa.

Pour les curieux , je rappelle le schéma d'un seul circuit ci-dessous (extrait de la datasheet de ce composant si fragile dans nos afficheurs):
UDN6118A.JPG
J'espère que tout ça servira à d'autres qui auront la même panne sur leur Sys1 ou Sys80.

Je vais maintenant pouvoir rendre un peu mon expérience sur un article (a venir) concernant la restauration complète du "Joker Poker". Bien sur cela a déjà été fait mais pour le coup je suis parti de 0 en terme d'expérience perso (c'est mon premier flipper) donc ça pourra toujours répondre à certaines questions que les experts de ce forum ne se posent même pas quand ils parlent de leur travail (merci à eux d'ailleurs car ils m'ont bien aidé par leurs articles quand je ne savais pas comment faire)

Répondre