Petits conseils en cas de problèmes

Répondre
Avatar du membre
yann
Site Admin
Dept: 38
Collec Perso: 0 flip
Rech/Achete: 0 flip
aimable donateur
Messages : 4684
Enregistré le : 01/10/2002
Niveau : Confirmé
Pro / revendeur : non
Localisation : Grenoble
Contact :

Petits conseils en cas de problèmes

Message par yann » sam. 10 07, 2004 21:20

Petits conseils en cas de problèmes

Les informations de cette page correspondent au premier WPC de 1991 et donc ne couvre pas le son DCS, le fliptronic, ni le WPC-S, ni WPC-95. Mais la plupart des infos peuvent être utiles pour toutes les générations de WPC.

Au programme :
  • Problèmes sur la carte CPU
  • Problèmes avec les contacts
  • Problèmes avec les lampes
  • Problèmes avec les bobines
  • Problèmes avec les lampes flash
  • Problèmes avec l'éclairage général
  • Problèmes avec le circuit de puissance
  • Problèmes avec l'afficheur alphanumérique
  • Problèmes avec le Dot-Matrix
  • Problèmes avec le son

Problèmes sur la carte CPU
La carte CPU a 3 leds situées en haut à gauche (D19, D20, D21). A la mise sous tension D19 et D21 s'allument un instant. Alors D19 s'éteint et D20 commence à clignoter rapidement. D21 reste allumée.
Le système a détecté un problème si :
  • D20 clignote une fois : erreur de ROM (U6)
  • D20 clignote deux fois : erreur de RAM (U8)
  • D20 clignote trois fois : erreur circuit U9

- Le jeu reste avec la configuration usine (Factory Settings) ou l'afficheur indique "'Factory Settings Restored"'.
Cela signifie que la mémoire CMOS RAM de la carte CPU ne mémorise pas la configuration souhaitée et retrouve donc sa configuration d'origine. Il est possible que les 3 batteries soient mortes ou qu'il y ait un mauvais contact.


- Le jeu affiche "'Time and Date Not Set"'
Le temps réel n'est pas actif. Il est possible que les 3 batteries soient mortes ou qu'il y ait un mauvais contact.

- erreur de ROM (U6)
Vérifier le circuit U6, c'est à dire le porte circuit s'il y en a un et les soudures. U6 est le circuit qui contient le programme du jeu.


Problèmes avec les contacts
-Le jeu démarre mais n'accepte pas de pièces et ne veut pas démarrer de partie.
Vérifier le fusible F115 sur la carte driver de puissance.
Vérifier le contact 13, celui du bouton start. Les fils blanc/orange et vert/marron doivent y être connectés.
Vérifier les connecteurs J206, J207, J208, J209 de la carte CPU.
Vérifier le circuit U20. Patte 1 à l'état haut, patte 18 à l'état bas.
Vérifier le circuit U18. Patte 5 et 2 doivent être à l'état bas.
Vérifier aussi D5.

-Tous les contacts d'une même colonne sont fermés ou ouverts.
Vérifier U20 et U14. Vérifier que le fil de cette colonne n'est pas relié accidentellement à la masse.

-Tous les contacts d'une même ligne sont fermés ou ouverts.
Vérifier la diode 1N4148 correspondante et le comparateur LM339. Voir aussi les circuits U13 et U15.

-Le jeu ne peut pas aller en mode test
Vérifier le contact de test à l'intérieur de la porte. Veiller à ce que le fil de masse soit connecté. Vérifier U15 et J16 et aussi le connecteur J205.

-2 (ou plus) contacts indépendants se ferment en même temps
Rechercher un problème de diode sur les contacts qui, en aucun cas, ne doivent être en conctact avec une partie métallique. Vérifier s'il n'y a pas un court-circuit sur la carte CPU entre ces deux contacts.

-Le jeu indique "'Check Switch #n"'
Signifie que le contact "'n"' n'a pas été activé pendant environ 30 parties. Vérifier le LM339 qui contrôle ce contact ainsi que U20. Veillez à ce qu'aucun fil ou diode n'ait été coupé ou dessoudé.

-Le jeu affiche "'Pinball Missing"' ou "'ball missing"'.
Une bille manque à l'appel (arrgghhh)! Elle est peut être coincée quelque part sur le plateau. Une autre cause peut être un défaut de détection de bille en sortie de plateau. Vérifier le LM339 qui contrôle ce contact ainsi que U20.

-Le jeu indique "'## Switch closed"' ou "'stuck On"'
Signifie que ce contact, qui est normalement ouvert, reste fermé. Ce contact est essentiel pour le jeu (détection de passage de pièce, tilt, etc). Vérifier que la colonne et la ligne de la matrice sont bien connectées et non court-circuitées.

-Le jeu indique "'Wht-xxx Row x Short"'.
Signifie que la ligne correspondante est reliée à la masse. Vérifier qu'un contact de la porte ne touche pas une masse. Vérifier aussi qu'un contact du plateau ne touche pas une partie reliée à la masse.

-Le jeu ne passe pas en mode "'Game Over"'
Peut-être un défaut de détection de bille en sortie de plateau. Vérifier le LM339 qui contrôle ce contact ainsi que U20.

-Les contacts des flips (11 et 12) ne sont pas détectés
Ce peut être soit U7 ou U8 sur la carte driver, ou U20 ou U18 sur la carte CPU.

-Les contacts de changment de couloir (ceux des flips) ne marchent pas
C'est, en général, dû aux circuits U7 (flip gauche) ou U8 (flip droit).



Problèmes avec les lampes
-Aucune des lampes (testées) de la matrice ne s'allume
Vérifiez la LED6 sur la carte driver de puissance. Si elle est éteinte, véfifiez F114 et BR1.
Si elle est allumée, vérifier U9 et U18. Ces deux circuits doivent avoir de grandes impulsions sur leur sortie. Vérifiez si le fil du +18V n'est pas débranché.

-Une ligne de lampe est soit très brillante, soit éteinte
Le TIP102 de cette ligne est généralement mort ou bloqué. Le comparateur LM339 est le composant suivant à vérifier. Le 74LS74 peut aussi en être la cause mais c'est plus rare.
Astuce : voici une méthode rapide pour tester un TIP102. C'est de relier la partie métalique du transistor à la masse. Si rien ne se passe c'est que le transistor est certainement en bon état, si la ligne s'allume, c'est qu'il est en mauvais état.

-Une colonne de lampe reste toujours allumée
Généralement, c'est le transistor TIP107 de la colone qui est défectueux.

-Une ligne de lampe reste toujours allumée
Généralement, c'est le transistor TIP102 de la ligne qui est défectueux.

-Quelques lampes ne s'allume jamais
Vérifier les ampoules et les porte-ampoules. Ainsi que les connexions (soudure froide, ligne ou colonne non conectée)

-Toutes les lampes sont allumées mais ne s'éteignent jamais
Généralement, c'est le composant U9 qui est responsable. U18 peut être coupable aussi.



Problèmes avec les bobines
-Aucune des bobines ne s'actionne
Vérifier le fusible F112 et le pont redresseur BR3.

-Un moteur ou un relais ne fonctionne pas
Vérifier le fusible F103, le transistor TIP102 qui pilote ce relais ou moteur et les fils correspondants. Enfin, c'est peut être ce relais ou moteur qui est défectueux.

-Une bobine ne veut pas s'actionner
Vérifier le transistor TIP36 et/ou le TIP102 qui commande la bobine. Vérifier le transistor 2N4403. Veillez à ce que le bobinage ne soit pas coupé et que les fils soudés à la bobine le soient bien. Vérifier la présence du +50V entre la bobine et la masse. Il est possible, mais peu probable, que le 74LS374 soit mort.

-Une bobine reste exitée
Le transistor TIP36 et/ou le TIP102 est grillé et est resté bloqué. Vérifier aussi le 2N4403.

-Une bobine a brulé
S'il y a une bobine brulée sous le plateau, c'est que la carte driver est certainement défecteuse aussi. Si vous remplacer la bobine sans vérifier la carte, cela risque de vous griller une nouvelle bobine.
La bobine elle-même peut avoir eu un problème. Sinon, cela vient du 74LS374 ou du transistor qui ont dû se court-circuiter. Une autre cause peut être le pont BR3, mais si c'était le cas, le fusible F112 aurait du fondre et il n'y aurait pas qu'une bobine détruite.
Vérifier bien que la bobine ne touche pas de partie métalique sous le plateau. Vérifier que le noyeau de la bobine peut bouger librement sans gêne.

-2 (ou +) bobines s'activent en même temps
Rechercher un court-circuit sur la carte driver de puissance. Vérifier le 74LS374 qui contrôle les bobines. Et rechercher un éventuel court-circuit entre ces deux lignes sous le plateau.

-Fusible F111 ou F112 fondu
Le pont BR3 ou BR4 est défectueux. Une autre cause peut être un court-circuit de lampe flash ou de bobine. Un défaut de relais ou de moteur peut aussi faire sauter ces fusibles.
Remarque : si le fusible F111 ou F112 fond plus d'une fois, c'est qu'il y a certainement un problème sur la carte driver de puissance.


Problèmes avec les lampes flash (LF)
-Une LF ne marche pas ou reste allumée
Après avoir vérifié la lampe, vérifiez le transistor TIP102 qui pilote cette LF, les fils et le support de l'ampoule. Le transistor 2N4403 peut aussi être le responsable.

-Aucune des LF ne fonctionne
Vérifier la présence du +20V sur les porte-ampoule, le fusible F111 et le pont BR4.

-Une ou plusieurs LF grille plus rapidement que les autres
Il y a certaiement une tension supérieure à +20V dans le circuit des LF. Vérifier la tension, si elle est supérieure à 20V, c'est qu'un fil est en contact avec une autre source de tension.
Si la tension est correcte, il faut voir les transistors TIP102.


Problèmes avec l'éclairage général
[*]Une ligne de lampe ne s'allume pas
Vérifier le fusible de cette partie. S'il est en bon état, vérifier la présence de la tension.
Si y a pas de tension, c'est que le fil est coupé.
Si il y a une tension, vérifier le triac qui gère cette ligne.

-Aucune des ampoules ne s'allume
Vérifier le circuit 74LS374, ainsi que la présence du 6.3V alternatif qui vient du transfo.

-Une seule ligne de lampes ne s'éteind pas
Généralement c'est le triac qui contrôle cette ligne qui est mort. Le circuit 74LS374 peut être à l'origine de ce disfontionnement.

-Aucune des lignes ne s'éteint
Généralement, voir le 74LS374 ou le comparateur LM339.


Problèmes avec le circuit de puissance
Si un circuit de puissance vient à ne plus fonctionner, vérifier d'abord le fusible et le pont redresseur correspondant.

Autres possibilités :
-Un court-circuit d'un support de lampe de l'éclairage général fait fondre les fusibles F106 à F110.
-Un court-circuit d'un support de lampe flahs fait fondre le fusible F111.
-Un court-circuit d'une bobine fait fondre les fusibles de F101 à F105 et F112.
-Un court-circuit du +5V fait fondre le fusible F113.
-Un court-circuit d'un support d'ampoule fait fondre le fusible F114.
-Un circuit U20 défectueux peut faire fondre le fusible F115.


Problèmes avec l'afficheur alphanumérique
-Des segments manquent
Généralement causé par un circuit UDN-7180 défectueux. Le 74LS374 peut aussi tomber en panne avec le UDN-7180.

-Des chiffres manquent
Généralement causé par un circuit UDN-6118 défectueux. Le 74LS240 peut aussi tomber en panne avec le UDN-6118.

-Pas d'affichage
Vérifier le fusible F301, et la présence du +/- 90V.



Problèmes avec le Dot-Matrix
-Il manque des points
Vérifier les connexions de l'afficheur (cassé, mal soudé...).

-Il manque une colonne de points
Un circuit driver de colonne est défectueux.

-Pas d'affichage du tout
L'afficheur ou/et la carte driver de l'afficheur sont défectueux, ou bien il n'y a pas la tension souhaitée.

-L'afficheur est illisible
La mémoire RAM sur la carte contrôleur est défecteuse.

[*]L'afficheur répète une mauvaise image
Un ou plusieurs circuit Latches qui vont à la mémoire RAM sont défectueux.


Problèmes avec le son
-Pas de son
Le circuit DAC AD7524 est défectueux.

-Pas de voix
Généralement, c'est le circuit CVSD 55536 qui est défectueux, ou l'ampli-op TL040, ou l'ampli TL082 qui est défectueux.

-Les voix sont déformées
Généralement, c'est le circuit CVSD 55536 qui est défectueux ou le 74LS74.

-Pas de musique
Généralement, les circuits YM3012 ou les YM2151 sont défectueux.

-Le volume est trop bas, et ça ne vient pas du potentiomètre
Vérifier les ampli-op TL084 et TL082.

-Rien du tout !
L'ampli audio LM1875 est certainement mort. Cet ampli doit avoir -26V sur sa broche 3, et +26V sur la patte 5. Sinon, c'est qu'il y a un problème. Les circuits ROM ou RAM doivent être défectueux. L'atténuateur MC3340 peut être aussi la cause.

-La carte est morte
Il n'y a peut être pas le +12 ou le -12V. Vérifier les fusibles F501 et F502.

-Le code son à la mise sous tension :
  • 1 bip = Carte son Ok
  • 2 bips = U9 RAM défectueuse
  • 3 bips = U18 ROM défectueuse
  • 4 bips = U15 ROM défectueuse
  • 5 bips = U14 ROM défectueuse

Avatar du membre
cyber_greg
Dept: 69
Rech/Achete: 0 flip
Messages : 3178
Enregistré le : 11/12/2008
Pas vu depuis 2 mois
Niveau : Expert
Pro / revendeur : oui
Localisation : Oullins (Lyon)
Contact :

Re: Petits conseils en cas de problèmes

Message par cyber_greg » mer. 24 02, 2016 17:34

yo!

je rajoute une piste pour les soucis de sons, sur un road king j'ais un souci qui est apparu d'un seul coup, la musique complètement ralentie, et les notes qui se mélangeaient ça faisait n'importe quoi, des fois ça fonctionnait, le problème est venu doucement, de temps en temps et de plus en plus fréquent jusqu'à permanant. uniquement les musiques aucun soucis avec les autres sons sfx etc... c'était en fait le processeur 68B09EP tout à droite de la carte son qui était naze.
Flipper L'esprit d'une vraie passion :) arcade

https://www.facebook.com/flipper.spirit.lyon

Répondre